# Docker Compose: Cannot start service ziti-controller-init-container:

**URL:** https://openziti.discourse.group/t/docker-compose-cannot-start-service-ziti-controller-init-container/552
**Category:** Building/Development
**Created:** [June 4, 2022, 5:55am UTC](https://openziti.discourse.group/t/docker-compose-cannot-start-service-ziti-controller-init-container/552 "2022-06-04T05:55:46Z")
**Posts on this page:** 9
**Page:** 1

<div class="post-metadata">

### Author: ![markamind](https://yyz2.discourse-cdn.com/free1/user_avatar/openziti.discourse.group/markamind/32/157_2.png) [@markamind](https://openziti.discourse.group/u/markamind)
#### Post date: [June 4, 2022, 5:55am UTC](https://openziti.discourse.group/t/docker-compose-cannot-start-service-ziti-controller-init-container/552/1 "2022-06-04T05:55:47Z")

</div>

Not sure what is causing this error when I run the docker compose command.

Its using /openziti/scripts/access-control.sh

instead of /image/access-control.sh file from what I observe.

sudo docker-compose -f /home/opc/demo/ziti/quickstart/docker/docker-compose.yml up

Creating network “docker\_zitiblue” with driver “bridge”  
Creating network “docker\_zitired” with driver “bridge”  
Creating volume “docker\_ziti-fs” with default driver  
Creating docker\_ziti-controller\_1 … done  
Creating docker\_web-test-blue\_1 … done  
Creating docker\_ziti-console\_1 … done  
Creating docker\_postgres-db\_1 … done  
Creating docker\_ziti-controller-init-container\_1 … error  
Creating docker\_ziti-edge-router-wss\_1 … done  
Creating docker\_ziti-fabric-router-br\_1 … done  
Creating docker\_ziti-edge-router\_1 … done  
Creating docker\_ziti-private-red\_1 … done  
Creating docker\_ziti-private-blue\_1 … done

ERROR: for docker\_ziti-controller-init-container\_1 Cannot start service ziti-controller-init-container: failed to create shim task: OCI runtime create failed: runc create failed: unable to start container process: exec: “/openziti/scripts/access-control.sh”: stat /openziti/scripts/access-control.sh: no such file or directory: unknown

ERROR: for ziti-controller-init-container Cannot start service ziti-controller-init-container: failed to create shim task: OCI runtime create failed: runc create failed: unable to start container process: exec: “/openziti/scripts/access-control.sh”: stat /openziti/scripts/access-control.sh: no such file or directory: unknown  
ERROR: Encountered errors while bringing up the project.

---

<div class="post-metadata">

### Author: ![markamind](https://yyz2.discourse-cdn.com/free1/user_avatar/openziti.discourse.group/markamind/32/157_2.png) [@markamind](https://openziti.discourse.group/u/markamind)
#### Post date: [June 4, 2022, 5:58am UTC](https://openziti.discourse.group/t/docker-compose-cannot-start-service-ziti-controller-init-container/552/2 "2022-06-04T05:58:37Z")

</div>

ahh… I noticed that those are specified in the yaml file… will update and try again.

I just cloned the repository… so I was not expecting this to be required

---

<div class="post-metadata">

### Author: ![markamind](https://yyz2.discourse-cdn.com/free1/user_avatar/openziti.discourse.group/markamind/32/157_2.png) [@markamind](https://openziti.discourse.group/u/markamind)
#### Post date: [June 4, 2022, 6:03am UTC](https://openziti.discourse.group/t/docker-compose-cannot-start-service-ziti-controller-init-container/552/3 "2022-06-04T06:03:10Z")

</div>

hmm. just realised that this directory is listed in the Docker file… maybe something is going wrong there

---

<div class="post-metadata">

### Author: ![markamind](https://yyz2.discourse-cdn.com/free1/user_avatar/openziti.discourse.group/markamind/32/157_2.png) [@markamind](https://openziti.discourse.group/u/markamind)
#### Post date: [June 4, 2022, 6:08am UTC](https://openziti.discourse.group/t/docker-compose-cannot-start-service-ziti-controller-init-container/552/4 "2022-06-04T06:08:04Z")

</div>

Did not change anything… still have the same error…

Any tips to resolve?

---

<div class="post-metadata">

### Author: ![gooseleggs](https://yyz2.discourse-cdn.com/free1/user_avatar/openziti.discourse.group/gooseleggs/32/450_2.png) [@gooseleggs](https://openziti.discourse.group/u/gooseleggs)
#### Post date: [June 4, 2022, 7:45am UTC](https://openziti.discourse.group/t/docker-compose-cannot-start-service-ziti-controller-init-container/552/5 "2022-06-04T07:45:50Z")

</div>

I have not had this problem, and I started with a clean slate yesterday. Running docker-compose up, I get this…

```auto
ziti-console_1 | ZAC will present this pem for TLS: /openziti/pki/ziti-controller-intermediate/certs/ziti-controller-server.cert
ziti-controller-init-container_1 |  
ziti-controller-init-container_1 | *****************************************************
ziti-controller-init-container_1 | docker-compose init file has been detected
ziti-controller-init-container_1 | the initialization of the docker-compose environment has already happened
ziti-controller-init-container_1 | if you wish to allow this volume to be re-initialized, delete the file
ziti-controller-init-container_1 | located at /openziti/access-control.init
ziti-controller-init-container_1 | *****************************************************
ziti-controller-init-container_1 |  

```

I grabbed the docker compose file as per curl link on [Local - Docker Compose | Ziti](https://openziti.github.io/ziti/quickstarts/network/local-docker-compose.html)

This is my docker-compose section

```auto
  ziti-controller-init-container:
    image: "${ZITI_IMAGE}:${ZITI_VERSION}"
    depends_on:
      - ziti-controller
    environment:
      - ZITI_CONTROLLER_RAWNAME="${ZITI_CONTROLLER_RAWNAME}"
      - ZITI_EDGE_CONTROLLER_RAWNAME="${ZITI_EDGE_CONTROLLER_RAWNAME}"
    env_file:
      - ./.env
    networks:
      zitiblue:
        aliases:
          - ziti-edge-controller-init-container
      zitired:
        aliases:
          - ziti-edge-controller-init-container
    volumes:
      - ziti-fs:/openziti
    entrypoint:
      - "/openziti/scripts/access-control.sh"

```

Try a `docker-compose pull` to ensure you are running the latest versions of the containers. By default, the version is `latest` which wont update when new releases are done. When you are in the zac, run a `ziti version` and it should be 0.25.10.

If it is not, then update to the later containers. The containers were updated only in the last few days.

---

<div class="post-metadata">

### Author: ![markamind](https://yyz2.discourse-cdn.com/free1/user_avatar/openziti.discourse.group/markamind/32/157_2.png) [@markamind](https://openziti.discourse.group/u/markamind)
#### Post date: [June 4, 2022, 10:02am UTC](https://openziti.discourse.group/t/docker-compose-cannot-start-service-ziti-controller-init-container/552/6 "2022-06-04T10:02:27Z")

</div>

hmm.. I think it was something related to the extra entries I added in re replication the postgres example..

> > I had a problem with the ziticontrol reference and commented it out  
> > not sure what this should be for it to work

postgres-db:  
image: postgres  
#ports:

# - 5432:5432

networks:  
#- ziticontrol  
- zitiblue  
volumes:  
- ./data/db:/var/lib/postgresql/data  
environment:  
- POSTGRES\_DB=postgres  
- POSTGRES\_USER=postgres  
- POSTGRES\_PASSWORD=postgres

---

<div class="post-metadata">

### Author: ![markamind](https://yyz2.discourse-cdn.com/free1/user_avatar/openziti.discourse.group/markamind/32/157_2.png) [@markamind](https://openziti.discourse.group/u/markamind)
#### Post date: [June 4, 2022, 10:10am UTC](https://openziti.discourse.group/t/docker-compose-cannot-start-service-ziti-controller-init-container/552/7 "2022-06-04T10:10:42Z")

</div>

all up an running now… I realised that maybe… #- ziticontrol was the problem…

As soon as I deleted it… all working as expected 🙂

---

<div class="post-metadata">

### Author: ![markamind](https://yyz2.discourse-cdn.com/free1/user_avatar/openziti.discourse.group/markamind/32/157_2.png) [@markamind](https://openziti.discourse.group/u/markamind)
#### Post date: [June 4, 2022, 10:44am UTC](https://openziti.discourse.group/t/docker-compose-cannot-start-service-ziti-controller-init-container/552/8 "2022-06-04T10:44:20Z")

</div>

One thing that I have noticed is the need to manually override the settings for ZITI\_BIN\_DIR

> > as shown below.. it doubles up on a folder directory

[opc@instance-20220518-1244 docker]$ source /dev/stdin \<\<\< "$(wget -qO- [https://raw.githubusercontent.com/openziti/ziti/release-next/quickstart/docker/image/ziti-cli-functions.sh](https://raw.githubusercontent.com/openziti/ziti/release-next/quickstart/docker/image/ziti-cli-functions.sh))"; getZiti

ZITI\_BINARIES\_VERSION: v0.25.10

**Using ZITI\_BIN\_DIR: /home/opc/.ziti/quickstart//ziti-bin/ziti-v0.25.10/ziti-bin/ziti-v0.25.10**

---

<div class="post-metadata">

### Author: ![markamind](https://yyz2.discourse-cdn.com/free1/user_avatar/openziti.discourse.group/markamind/32/157_2.png) [@markamind](https://openziti.discourse.group/u/markamind)
#### Post date: [June 4, 2022, 10:46am UTC](https://openziti.discourse.group/t/docker-compose-cannot-start-service-ziti-controller-init-container/552/9 "2022-06-04T10:46:05Z")

</div>

Ps… there is also a double // in the file path .

Marking executables at /home/opc/.ziti/quickstart//ziti-bin/ziti-v0.25.10 executable
