# Docker Compose for Oracle Linux: could not read configuration file \[/persistent/ziti-edge-controller.yaml

**URL:** <https://openziti.discourse.group/t/docker-compose-for-oracle-linux-could-not-read-configuration-file-persistent-ziti-edge-controller-yaml/1014>\
**Category:** Ziti Overlay\
**Created:** [January 29, 2023, 11:03am UTC](https://openziti.discourse.group/t/docker-compose-for-oracle-linux-could-not-read-configuration-file-persistent-ziti-edge-controller-yaml/1014 "2023-01-29T11:03:05Z")\
**Posts on this page:** 1\
**Showing post:** 6

<div class="post-metadata">

**Author:** ![gooseleggs](https://yyz2.discourse-cdn.com/free1/user_avatar/openziti.discourse.group/gooseleggs/32/450_2.png) [@gooseleggs](https://openziti.discourse.group/u/gooseleggs)\
**Post date:** [January 29, 2023, 7:04pm UTC](https://openziti.discourse.group/t/docker-compose-for-oracle-linux-could-not-read-configuration-file-persistent-ziti-edge-controller-yaml/1014/6 "2023-01-29T19:04:28Z")

</div>

Well done for getting this solved! Looking at the logs, I gather you used docker-compose on this host awhile ago, and then just come back to it, updated the docker-compose and ran into this trap?!. I am thinking this because of

> [@markamind](#):
>
> [3.794] FATAL edge/controller/subcmd.configureController: {error=[unable to load identity (open /openziti/pki/ziti-controller-intermediate/keys/ziti-controller-server.key: no such file or directory)]} could not read configuration file [/persistent/ziti-edge-controller.yaml]
> 
> ```auto
> 
> ```

in particular, this part `/openziti/`. A few months ago, there was a breaking change for the docker-compose environment, and a rejig of locations. `/openziti` no longers exists, and it is now `/persistent`. This was done for a couple of reasons, but the major one was because updating the container DID NOT update the binary components (well it did in the container, but they were referencing the old one in the `/openziti` volume.

For completeness, Geoff put instructions here: [Bump on openziti docker images please - #10 by gberl002](https://openziti.discourse.group/t/bump-on-openziti-docker-images-please/916/10) on how to migrate.

@TheLumberjack think we should update the documentation with reference to this change to help anyone else who might come across this.

So, in your case, removing the docker volume (`docker volume rm ziti-fs`) would have most likely resolved the problem (meant starting from fresh), or having the article available could have meant fixing up without having to start at ground zero.

Either way, great job!

---

_[View the full topic](https://openziti.discourse.group/t/docker-compose-for-oracle-linux-could-not-read-configuration-file-persistent-ziti-edge-controller-yaml/1014)._
