# Ziti Tunneler on Windows not working

**URL:** <https://openziti.discourse.group/t/ziti-tunneler-on-windows-not-working/1196>\
**Category:** Support\
**Created:** [April 10, 2023, 3:41pm UTC](https://openziti.discourse.group/t/ziti-tunneler-on-windows-not-working/1196 "2023-04-10T15:41:18Z")\
**Posts on this page:** 1\
**Showing post:** 3

<div class="post-metadata">

**Author:** ![Foles\_90](https://avatars.discourse-cdn.com/v4/letter/f/a8b319/32.png) [@Foles\_90](https://openziti.discourse.group/u/Foles_90)\
**Post date:** [April 10, 2023, 5:12pm UTC](https://openziti.discourse.group/t/ziti-tunneler-on-windows-not-working/1196/3 "2023-04-10T17:12:20Z")

</div>

Hey, thanks for the quick response.

Just FYI, “[myapp.com](http://myapp.com)” is the name that I am using here, the URL of my app is different.

The VM hosting the tunneler can reach the app, which is why when I use the IP address instead of the URL in the service config it works fine.  
Also, the app has a public DNS record and it is accessible over the internet, there are no private URLs or IPs in this environment.

On the app side, there is a firewall rule allowing traffic only to the public IP of the VM where OpenZiti is hosted.  
It is the same scenario as: [Tunneler stop working - #15 by Foles\_90](https://openziti.discourse.group/t/tunneler-stop-working/1108/15)

I checked the logs and this is the error that I am seeing:

```auto
ERROR tunnel-cbs:ziti_hosting.c:394 on_hosted_client_connect() hosted_service[vault.service], client[Laptop]: getaddrinfo(myapp.com,443) failed: No such host is known. 

```

however, if I do a “nslookup [myapp.com](http://myapp.com)” from the VM hosting the tunneler it can resolve the name without any issues

---

_[View the full topic](https://openziti.discourse.group/t/ziti-tunneler-on-windows-not-working/1196)._
