Best practices of securing controller (and ZAC)

Found the issue! I’ve installed v18.15.0 via nvm but there was a globall node v16.x installed which resulted in missing version dependencies.
But still can’t connect using my service. Which port is used on the ziti sdk side - the configured http or https port for ZAC?

You said:

I’m on 2.6.6 now

Make sure you are on 2.6.7.

When you run you should see output that resembles the following:

> io.netfoundry.zac@2.6.7 zitified
> ZITI_IDENTITY_FILE=zac-identity.json ZITI_SERVICE_NAME=test-service node server.js

Loading Settings File From: /Users/curt/demo/ziti-console/../ziti/settings.json
Ziti Admin Console is now listening for incoming Ziti Connections

Your values for the ZITI_IDENTITY_FILE and ZITI_SERVICE_NAME may vary.

Hm, current version on Github is 2.6.6 or am I missing something?

The package.json currently on the master branch has 2.6.7. Looks like the version.txt file wasn’t kept in lockstep, but that won’t impact anything related to this thread.

If you have pulled the latest from master, you’re good.

Just do a npm i in your local repo, and that should install the @openziti/ziti-sdk-nodejs version 0.13.3.

If that succeeds, you should be able to set your values for the ZITI_IDENTITY_FILE and ZITI_SERVICE_NAME and then start your zitified ZAC by running:

ZITI_IDENTITY_FILE=your-identity.json ZITI_SERVICE_NAME=your-service node server.js