Created terminator panic: runtime error: index out of range

I am preparing a demo using the golang zping service

When I revisited this… as I had this working a while ago… I now receive the following error in the controller log when running the zping client service

./zping client -c zping.json -i ziti-ping -n 5

created terminator panic: runtime error: index out of range

When this happens, the controller stops running.

Maybe I need to update to the latest version of OpenZiti… and try again…

Any tips?

Without a full and complete list of steps that you’re doing from start to finish it’s hard to know for sure. Regardless, any panic is entirely unexpected. If you can reproduce with steps, and it’s reproducable on the latest build of ziti, it’d be much appreciated if you an file a bug against the main GitHub - openziti/ziti: The parent project for OpenZiti. Here you will find the executables for a fully zero trust, application embedded, programmable network repo.

I’d say, try building a fresh install, maybe try using the docker compose setup to see if it happens there. If you can find the panic from the controller, that’d be useful. There’s probably a panic in those logs if the controller stoped running

1 Like

I just downloaded the latest repo… and tried the curlz example with the same result.

Maybe I need to update the golang version from which the curlz app was complied in.

I will investigate this a bit further.

Think I found the cause… it was related to SELinux… as I needed to reactive this to update the yum repo.

When I disabled it… the error went away… but I now get another issue…

panic: Get "http://httpbin.svc": unable to dial service 'httpbin.svc': dial failed: service 5mXNUKyjB has no terminators for instanceId

Maybe… I still have something to disable… because I can confirm that the terminator has been created… but for some reason… it is not being acknowledged

I am a bit rusty with this…

Let me know if there is anything I can do to confirm all is OK… I ran the policy-advisor which did not identify any issues.


I think I have this one now… I have the edge router located on the wrong server… hence why it cannot connect. :slight_smile: