Error using zrok frontdoor

Hi all,
I've got a digital ocean droplet and I'm trying to use zrok frontdoor to host some static files.

Everything looks good on my API account but when I click the frontend URL I get sent to the "not found" page. After looking at the logs I'm seeing this as the most recent log entry:
unable to create share (unable to create share: [POST /share][500] shareInternalServerError)

I saw a couple closed issues on the github that contained this same error, but it looks like those issues were fixed.

Any ideas on how to proceed?

EDIT: I just tried commenting out the ZROK_UNIQUE_NAME="matrweb2" line I had and now it works, however I'd like to be able to set the name...
Maybe some issue with this name?


My first guess is that unique name was claimed by a previous attempt, and then perhaps the reserved.json file was deleted causing the script to try reserving it again. Does it work with a different unique name? You're using the zrok-share package or the Docker Compose example?

I was able to fix this by using zrok release and or a unique name change.

1 Like