Find_dns_updater() could not find a way to configure system resolver

Hi,
today suddenly the Ziti Edge Tunneler crashed on my Debian server. Any idea what the reason could be? Restarting doesn’t solve the problem, neither restarting the service nor restarting the whole server.

(10900)[        0.000]    INFO ziti_log_set_level set log level: root=2
(10900)[        0.012]    INFO ziti_log_set_level set log level: root=2
(10900)[        0.012]   ERROR ziti-edge-tunnel:tun.c:251 find_dns_updater() could not find a way to configure system resolver. Ziti DNS functionality will be impaired

Sorry to hear that, @dmuensterer . Let’s increase the logging level and collect some intel on your environment.

First, make sure you’re running the latest tunneler: Linux | OpenZiti

You can check the version:

ziti-edge-tunnel version

You can change the verbosity for the package-installed tunneler in this file:

$ cat /opt/openziti/etc/ziti-edge-tunnel.env
ZITI_IDENTITY_DIR='/opt/openziti/etc/identities'
ZITI_DNS_IP_RANGE='100.64.0.2/12'
ZITI_VERBOSE=6
UV_MBED_DEBUG=4
ZITI_LOG=6

When you say “crash”, was it a fatal error, segfault, or something else, if you know?

If it’s a segfault then it will be helpful to obtain the corefile. Here’s some troubleshooting tips: Troubleshooting | OpenZiti

There was nothing like a segfault.
By ‘crashing’, the tunneler didn’t work anymore and show the error message above.
Interestingly enough, it did work again after a restart, the message remains but it still works - not sure what the cause might be.

This error means the tunnel is running, but it couldn’t auto-configure your operating system’s DNS resolver. You may still be able to configure your OS to use the built-in nameserver provided by Ziti.

Since your tunnel stopped working, I’m guessing this means that DNS resolution stopped working, but the tunneling process kept running.

We can diagnose this by looking more closely at the symptoms you experienced when the tunnel stopped working. If DNS is failing, you’ll see an error like “unknown host” or “NXDOMAIN.”

Let’s make sure your OS is configured to use the Ziti nameserver. Since auto-configuration failed, your OS probably doesn’t use systemd-resolved. Is enabling an option, or are you already using something else to manage nameservers, e.g., Network Manager?