[Resolved] Unable to Execute zrok in shell on pi 4

No matter if I add it to my path per the docs, move the executable to /usr/bin and launch, or just launch from the extracted location, I always get -bash: ./zrok: No such file or directory

This is on a Pi 4, running the latest Raspberry Pi OS, with the arm version of zrok downloaded and extracted to a previously-empty and dedicated folder.The error persists even if I run chmod +x zrok. The current permissions for the zrok executable is -rwxr-xr-x.

Hi @ThaneVim, thanks for the post and welcome the zrok and the community!

I was able to reproduce that problem using a different arm7 archetecture. Looking at the file it’s marked as:

file zrok
zrok: ELF 32-bit LSB executable, ARM, EABI5 version 1 (SYSV), dynamically linked, interpreter /lib/ld-linux.so.3, BuildID[sha1]=1de051ff17e566be3c066cba101bda11a095d222, for GNU/Linux 3.2.0, stripped

We’ll have to take a look. We’ll follow up in a bit

Hi @ThaneVim , Will you try the 64bit download on your Pi 4?


1 Like

That worked! Not sure how I missed that release on the releases page, but it is now running on my Pi. Thanks!!

1 Like

Do you know if you’re running 64bit RasPi OS? What does uname -m say?

It is 64-bit, with uname -m returning aarch64.

And I knew that, but for some reason just glazed over the arm64 release on the releases page for Zrok, opting to download the regular arm version. Everything is working properly with the arm64 version downloaded. I think I just read arm64 as amd64? Either way, my failing.

1 Like

Sadly, it caught me too! :slight_smile: I had downloaded the arm7 build and didn’t realize it… Thanks @qrkourier for straightening us both out!

1 Like

Thanks for the info. Good luck with zrok!