Tunnel Requires Internet To Install

I am trying to install a tunnel on one of our lab machines to test network connectivty and the edge client will not install without internet access

“how” are you installing it? You can always just “download and run it”:

wget https://github.com/openziti/ziti-tunnel-sdk-c/releases/download/v0.20.18/ziti-edge-tunnel-Linux_x86_64.zip
unzip ./ziti-edge-tunnel-Linux_x86_64.zip
./ziti-edge-tunnel --help


I am downloading the windows version I have downloaded the source code and it will not run

For windows it errors out because it is looking to go out to the internet which it can’t because it is an offline lab

Hunh. I’ll have to try to emulate that. I don’t know if I have a nice way to do it. What/how did the ZDEW fail? Do you have logs to share? you can send them to clint at openziti.org if you want me to peek at them.

Is it the UI that fails or something else?

  1. The exe download requires going out to the web it fails saying no online connection
  2. The download of the source code is failing mainly because it also asks for internet access to build which makes no sense so maybe I am doing it wrong

The go build will always download dependencies. I expect that’s why your build fails? Aside from that, I’m going to disconnect my internet entirely and start up and see what happens for me. I don’t know of any reason why that wouldn’t work… Here’s what I’m going to do:

  • remove all my ZDEW identities (well imma back them up)
  • stop the ZDEW
  • bootstrap an entire environment in my WSL using the quickstart
  • turn on the ZDEW
  • see if it enrolls/connects

That seem like a reasonable test?

Seems like a good test to me

Oh the installation is what is failing. Hrm… That’s a different beast for sure. @jeremy.tellier seems like another thing for the installer to be able to handle?

Actually wait - that first error is at install and that second error is during build time?

One of them i was trying to build from source code and failed at it

the other was the installer that is ready and downloadable

I can change the installer to work even when there’s no internet connection. Right now it’s enforcing that but it’s an easy toggle. I’ll add an issue for that. Until then, I don’t know if you’ll be able to succeed at installing it

Ok let know when the installer would be good to download and I can move forward with install and network connections. I have other items I lam learning about the Ziti product that will also take time

Is the toggle something I would be able to do on my end to install it or am I just going to have to wait for the updated installer to be pushed?

I’ve made a beta build here. you’ll need to be authenticated to github to download it helps if you update the proper installer · openziti/desktop-edge-win@0dde102 · GitHub

If you can’t get it let me know and I’ll share it differently. I was able to get that installed in my windows sandbox without internet

You’ll have to wait for an official release. The github issue is here Allow ZDEW install even when offline · Issue #595 · openziti/desktop-edge-win · GitHub and the PR to fix it is here Beta release offline install by dovholuknf · Pull Request #597 · openziti/desktop-edge-win · GitHub

Just wanted to pass this on for history tracking

Items Tried:

  1. Installing Cert from properties
  2. Allowing install even with invalid certs (this should have fixed it believe there is a further setting)

Hunh. Not sure how we’ll be able to figure that one out. I don’t think it’s related to the release process since the CI machinery built this artifact. I’ll try it again on my windows sandbox. Is there anything “special” about the windows installation at all? Any specs/hints you can give me is helpful. You’re not running windows in a M1 Mac for example, right?

Actually let’s test the SHA of that file you copied/downloaded… If you run this from powershell:

Get-FileHash '.\Ziti Desktop Edge Client-2.1.14.exe'

Algorithm       Hash                                                                   Path
---------       ----                                                                   ----
SHA256          7C61DBBB5D5DEABCB9CB34E720D1673F8FD1CAA635C4DFF33B9DE839E2ECEE15       C:\Users\WDAGUtilityAccount\D...

Do you get that hash?

I do get that hash value

Its a standard windows install on a dell desktop made for windows I believe there is a local group policy blocking it I will do a deeper dive