Can't copy large files via webdav through ziti

I recently set up a CloudZiti network just for my personal file server. I have just two endpoints, my MacBook Pro, and my Mac Pro, which hosts the file server. I have two Netfoundry hosted edge routers set up, and both are configured in the service. When connecting to the file server through ziti, I can’t copy large files off the server. Copying To works, but copying From doesn’t. Whether I copy via the webdav share mounted through Finder or download the file via the webinterface on my file server software, it gets an error that the operation could not be completed. I verified it is working as expected when I connect locally to the webdav/webinterface, so the issue is not with the file server software. Additionally, I know my connection is working, as any files under ~100MB or so copy without error, both directions.

Looking in my ziti web console, my Mac Pro doesn’t show any errors, but in the dial logs for my MacBook Pro, there are failures every time I try to copy a file from the server, but the error type is just “ROUTER_ERR_GENERIC”, which doesn’t give me a whole lot of diagnostic info. Looking at the log file generated by the ziti desktop edge on my Mac Pro, I see a bunch of errors similar to “ziti_write to Logan-mbp failed: invalid state”.

Any thoughts on what could be causing this?

Interesting issue. Is there any way you could provide the steps you use to produce this particular scenario? It would also be really helpful if you allowed us to look at your logs. I’d like to see three sets of logs, the initiating MacOS tunneler, the receiving MacOS tunneler and the router(s) logs. If you could send those to help at, we can take a look.

It sure seems like some kind of bug but without being able to reproduce it exactly it’s gonna be hard to narrow down. The logs might help us find it though.

As for :

Not many!! :slight_smile: That’s a strange situation. Hopefully though, if you share the logs we might be able to formulate one


So I did some more testing myself, and found it was an issue with the older Ziti Desktop Edge client! I found another post elsewhere, (Though I can’t track it down now) from someone with a similar issue, and the comments essentially determined what you suspected, it was a bug, which has been patched in the later release of the Desktop Edge client for macOS. Unfortunately, that newer version of the client requires Monterey or later (A very steep requirement), so my current server machine which caps at Big Sur can’t do it. Time for a hardware upgrade anyways! So, problem has been solved, technically. While I am running into a Different error, I’ll start a new topic for that, for ease of searchability should someone else run across that problem.

Thanks very much for that update. Glad to hear it’s “solved” (in a way) :slight_smile: I’ll look for your new topic, thanks for starting a new topic btw, I appreciate that!

Are you running Big Sur (MacOS 11)?

Yep, Big Sur 11.5.2. I haven’t run dot release updates, since it’s running via OCLP on a '09 Mac Pro, so not exactly a supported update, and more hassle than it’s worth to upgrade to Monterey.

Would you be open to accepting a TestFlight build for 11.5 and helping us potentially address some compatibility issues? If so, send me a DM with your email address and I’ll invite you to give it a try.

That would be excellent, but it looks like TestFlight won’t install on Big Sur anymore… requires macOS 12.0 or later, and I’m not seeing any option to download the older version like you can for most apps, any suggestions? As a slightly related question, any plans in the roadmap to have a non-app store version of the desktop edge for Mac?


We’ve looked into it for this app, and it’s not a small lift. If you search this site, you’ll find some folks who have had success running ziti-edge-tunnel on macOS, which might be a better fit for your server-side deployment, regardless.

Understood, I likely will look into setting up with the CLI on the server side going forwards. The biggest reason I’d want a non-app store version is not for my server machine though, but rather for sending to client machines. While the “Share” function for newly created endpoints in the Netfoundry console is great, I’d love an option to just create a package installer with the .jwt and app bundled into one, and send that to a friend for one-click install and connection.