Can't login to OpenZiti

I dont know why but since today and yesterday enabling MFA on the policy's i now cant login to the ziti console and zitiLogin, logs of the controller service tells me that the admin identity is disabled?

Mar 19 12:44:15 24x7-openziti ziti[413]: {"authMethod":"password","authenticatorId":"J0XiqhzRWQ","disabledAt":"2024-03-19T09:16:05.504395743Z","disabledUntil":null,"file":"","func":"*AuthModuleUpdb).Process","identityId":"k5Ndtf9DM","level":"error","msg":"authentication failed, identity is disabled","time":"2024-03-19T12:44:15.978Z","username":"admin"}

How do i get this working again?

1 Like

Hi @toms24x7,

Identity is disabled -- did you happen to change any authentication polices lately or maybe edit the admin using ZAC and change anything on the identity? We had a user disable their admin by mistake very recently on this thread: Re-enable default admin

Maybe it's relevant? Did you do the same thing as them perhaps?

1 Like

I am not sure what happend, yesterday it was working just fine with MFA.
Maybe I did change something with the authentication policies, just dont know anymore.
When I tried to login this morning it just wouldn't let me.

In your linked forum they can still login into ziti CLI which I cant.
I am reinstalling Ziti anyway as it is quite a dirty VM for all my troubleshooting.

1 Like

Interesting. I've seen people change the auth policy for all users and unintentionally cause this kind of problem before. My guess is that's what happened. Since you're dumping it and starting over -- we'll never know :slight_smile: If you do happen to remember the sequence, please post back. Cheers!

1 Like

When I'm done reinstalling I will take a snapshot of the VM before changing some things with the Auth policy. If I can reproduce this issue I will let you know again


Tried a few settings to reproduce of what I might have changed yesterday but sadly could not reproduce the issue.

Everything works fine now after reinstall of the VM :slight_smile:

1 Like