Community Feedback Request - ziti edge quickstart

Hi All,

OpenZiti v0.30.4 has been released containing a new feature and we are looking for community feedback.

The feature is ziti edge quickstart. This command is intended to be used for short-lived networks, suitable for unit testing, playing around locally while learning OpenZiti or who knows! You tell us how you'll use it! Run ziti edge quickstart --help to explore the command.

What do you think? What features would you like to see added to it?

Here's a short demonstration video for those interested:


Very cool. It will greatly reduce the effort to organise a demo. Awesome.

1 Like

This appears to support PowerShell on Windows AMD64 at this time. Are there plans to support macOS Apple silicon?

It's funny you should ask that. I ended up giving it a try last night and realized it just blindly downloads the windows version cause... Powershell == Windows right??? :slight_smile:

I do plan try it out on linux/macos when I can find the time to. FWIW you don't need to wait for powershell support though.

source /dev/stdin <<< "$(wget -qO-"; getZiti "yes"

should be the one-liner to get the latest version of ziti on your machine (until we add brew support, which we'll do at some point i am sure)

1 Like

LOL...I actually do have powershell installed on my M1 MacBook (but I can't recall why). I did try to install the powershell version and I ran into what you described.

I had assumed there was some powershell-only magic in the latest release.

This looks really cool, will give it a try.

Fantastic. My main use for it now will be for setting up quickly on site or testing on prem. As previously, I was using a snap shot system on a VM for this exact purpose!

In the future when I get it know OpenZiti more intimately. It would make a great training aid for the cli with trainee staff.

1 Like

FWIW I installed powershell via homebrew because vcpkg was having a fit about it.

I ran this on a newly created Debian VM. I had not installed jq and I got a message indicating that the bin dir was not set: * ERROR: ZITI_BIN_DIR is not set (but I think this might be a warning because the default dir was used).

oh so it didn't check for pre-requisites? it should definitely do that. i'll try it on a docker image and file a bug:

issue filed : getZiti fails when pre-req's are not met · Issue #1375 · openziti/ziti · GitHub

1 Like
source /dev/stdin <<< "$(wget -qO-"; getZiti "yes"
  * ERROR: ZITI_BIN_DIR is not set
ZITI_HOME overridden: /home/username/.ziti/quickstart/zt01
-bash: jq: command not found
-bash: jq: command not found
The path for ziti binaries has not been set, use the default (/home/username/.ziti/quickstart/zt01/ziti-bin/ziti-)? (Y/n) y
INFO: using the default path /home/username/.ziti/quickstart/zt01/ziti-bin/ziti-
Getting OpenZiti binaries

Alright @carljmosca ... I have PR up to fix getZiti.ps1 for those of us crazy enough to run and try powershell on non-windows OS'es... If you want to try the preview, run:


I tried it on macos arm, linux and windows so hopefully it'll work for everyone so inclined to try it.

Windows - Linux - MacOs:


1 Like

Awesome!! Yes, it works nicely on macOS (M1 hardware). Will make some time to play around with it a bit more. Thank you @TheLumberjack