Docker Compose Blue Edge Router configured as a private edge router

Not sure if this the expected configuration, but I noticed the Blue Edge router was configured as a private edge router… as the following listener section was commented out.

I realised this happened because I setup my configuration so that this is a public edge router.

All ok if its expected… I know a lot has changed since the last time I used this setup


    - binding: transport
#  listeners:
#    - binding:          transport
#      bind:             tls:
#      advertise:        tls:ziti-private-blue:10080
#      options:

Ahh my mistake… I just realised that it is a private edge router…

The public edge router is “ziti-edge-router”

It’s been a while since I last used some of the scripts that I am working with.

Yep. That docker-compose quickstart was meant to serve as inspiration and learning, but we clearly need to make containers that are meant for deployment/long-term operation. We’re working on that now.