Ubuntu Focal expressInstall fails

I am trying to install OpenZiti on Ubuntu 20.04 on my free Oracle Compute Cloud instance. The expressInstalle seems to have some difficulty at this point:

******** Setting Up Environment ********
using default ZITI_HOME: /home/ubuntu/.ziti/quickstart/alpine
ZITI HOME SET TO: /home/ubuntu/.ziti/quickstart/alpine
jq: error (at :0): Cannot iterate over null (null)
ZITI_BINARIES_VERSION: null
Downloading https://github.com/openziti/ziti/releases/download/null/ to /home/ubuntu/.ziti/quickstart/alpine/ziti-bin/
UNZIPPING /home/ubuntu/.ziti/quickstart/alpine/ziti-bin/ into: /home/ubuntu/.ziti/quickstart/alpine/ziti-bin/ziti-null
tar: /home/ubuntu/.ziti/quickstart/alpine/ziti-bin/: Cannot read: Is a directory
tar: At beginning of tape, quitting now
tar: Error is not recoverable: exiting now
mv: cannot stat ‘/home/ubuntu/.ziti/quickstart/alpine/ziti-bin/ziti’: No such file or directory
Marking executables at /home/ubuntu/.ziti/quickstart/alpine/ziti-bin/ziti-null executable
chmod: cannot access ‘/home/ubuntu/.ziti/quickstart/alpine/ziti-bin/ziti-null/*’: No such file or directory
Generating new network with name: alpine
ZITI_NETWORK set to: alpine

I am open to some suggestions as I really want to get this going! Thanks much.

On Oracle cloud you made a new ubuntu 20.04, and ran the quickstart and it failed? The “cannot iterate over null” makes me think the github check has failed.

I’ll make a new oracle cloud ubu 20.04 and give it a shot right now and see if i can replicate.

Thank you so much! I don’t know what’s going on here. Admittedly I am new to Linux. I am an OpenBSD guy

Sure. Here’s the image I’m selecting…

Yep! That’s the same one I am using.

Just curious but what are your thoughts so far?

Unfortunately, it worked just fine for me. You do need to make sure the oracle web acl allows ports 8440-8443 and when I started the Ubuntu instance iptables was setup to block the ports as well. That meant I had to use iptables to open them up:

sudo iptables -I INPUT -p tcp -m tcp --dport 8440 -j ACCEPT
sudo iptables -I INPUT -p tcp -m tcp --dport 8441 -j ACCEPT
sudo iptables -I INPUT -p tcp -m tcp --dport 8442 -j ACCEPT
sudo iptables -I INPUT -p tcp -m tcp --dport 8443 -j ACCEPT

After that - things worked fine. Based on your jq error though, I expect you have hit a github rate limit from your exit IP. The quickstart will use the github api to determine the latest version of ziti to install, it does this by making a curl request and then using jq to parse that output. Seeing the “cannot iterate over null” means something “strange” happened.

Since I know it worked fine for me, let’s try to narrow down your particular problem. Let’s run this command:

clear; source /dev/stdin <<< "$(wget -qO- https://get.openziti.io/quick/ziti-cli-functions.sh)"; getZiti yes

Attach your output here. This is what you should see:

ZITI_BINARIES_VERSION: v0.27.4
Using ZITI_BIN_DIR: /home/ubuntu/.ziti/quickstart/ubu-20-04/ziti-bin/ziti-v0.27.4
Downloading https://github.com/openziti/ziti/releases/download/v0.27.4/ziti-linux-amd64-0.27.4.tar.gz to /home/ubuntu/.ziti/quickstart/ubu-20-04/ziti-bin/ziti-bin/ziti-linux-amd64-0.27.4.tar.gz
UNZIPPING /home/ubuntu/.ziti/quickstart/ubu-20-04/ziti-bin/ziti-bin/ziti-linux-amd64-0.27.4.tar.gz into: /home/ubuntu/.ziti/quickstart/ubu-20-04/ziti-bin/ziti-v0.27.4
mv: cannot overwrite non-directory '/home/ubuntu/.ziti/quickstart/ubu-20-04/ziti-bin/ziti-v0.27.4/ziti' with directory '/home/ubuntu/.ziti/quickstart/ubu-20-04/ziti-bin/ziti-bin/ziti'
Marking executables at /home/ubuntu/.ziti/quickstart/ubu-20-04/ziti-bin/ziti-v0.27.4 executable
Adding /home/ubuntu/.ziti/quickstart/ubu-20-04/ziti-bin/ziti-v0.27.4 to the path if necessary:
adding /home/ubuntu/.ziti/quickstart/ubu-20-04/ziti-bin/ziti-v0.27.4 to the path

Okay, that seemed to work:
using default ZITI_HOME: /home/ubuntu/.ziti/quickstart/
ZITI_BINARIES_VERSION: v0.27.4
Downloading https://github.com/openziti/ziti/releases/download/v0.27.4/ziti-linux-amd64-0.27.4.tar.gz to /home/ubuntu/.ziti/quickstart//ziti-bin/ziti-linux-amd64-0.27.4.tar.gz
UNZIPPING /home/ubuntu/.ziti/quickstart//ziti-bin/ziti-linux-amd64-0.27.4.tar.gz into: /home/ubuntu/.ziti/quickstart//ziti-bin/ziti-v0.27.4
Marking executables at /home/ubuntu/.ziti/quickstart//ziti-bin/ziti-v0.27.4 executable
Adding /home/ubuntu/.ziti/quickstart//ziti-bin/ziti-v0.27.4 to the path if necessary:
adding /home/ubuntu/.ziti/quickstart//ziti-bin/ziti-v0.27.4 to the path

Ok. At this point, it’ll be best if you exit the shell from Oracle, (log out/exit) and then ssh back there. Do that just to clear any variables set in your shell and start the quickstart fresh… Before running the quickstart, let’s clean up everything using: rm -rf $HOME/.ziti and then start at the quickstart begginning. I also set my EXTERNAL_DNS to the external IP address (oracle doesn’t give you a DNS entry).

I used the DNS entry that I created off of my own DNS server … Will do

Oh! Well then by all means use that!!! :slight_smile: Also I forgot to say, Welcome to the forum and OpenZiti! My bad :slight_smile: I always greet new users…

Thanks! Are you Phillip from reddit by any chance?

1 Like

OUCH!!! :stuck_out_tongue_closed_eyes: Nope. We can mention him though and I’m sure he’ll reply tomorow lol. Isn’t that right @PhilipGriffiths

1 Like

Oh I am sorry then. He was the very kind gentleman that referred me here. Yay!! Success. Now let me try and manually start the router and controller.

1 Like

It’s all good - he is a very kind gentleman! Sounds like you got through that first bit, awesome. The rest should be a breeze. I’ll be around if you need more help.

Uh oh. The router failed to start:
[3]+ Exit 1 “${ZITI_BIN_DIR}/ziti-router” run “${ZITI_HOME_OS_SPECIFIC}/${ZITI_EDGE_ROUTER_RAWNAME}.yaml” > “${log_file}” 2>&1

@ablackcatstail and I have been DM’ing. They followed the blog from @gberl002 Setting Up Oracle Cloud To Host OpenZiti

BUT - it was writen before we changed from port 6262 to 8440 for control plane access. I’ll update the blog post and keep DM’in with @ablackcatstail and get them up and running

I’m happy to report that after updating the Oracle ACL to allow the new port 8440, @ablackcatstail was able to get up and running.

It also exposed a problem with our oracle blog which I fixed. People will now see:

2 Likes

can you provide a link to the Oracle blog? not sure I was aware of that

surely! Setting Up Oracle Cloud To Host OpenZiti