Unable to create share error 401

I created a new account its token is working but in the first account its is not working. I was checking some features of zrok account panel i think that i pressed some button or anything . Is there a way to fix it/revert the changes

Hi there :wave: @ShashwatDubey99. Welcome to the ziti and zrok forum.

It looks like your Windows zrok environment was enabled, but got disabled in the web console.

The fix is to re-do the zrok enable command with the same account token you used before. If you need the token, you can find it in the web console. Here's a picture: Getting Started with zrok | Zrok

I thought the same thing as this is windows problem but when tried on my linux device , cloudvms and the colab notebooks same thing is happening. I tried token of another account and it work the token from previous account is not working , as I said i think thats a problem with account panel , can i revert changes or anything using site ?

The zrok account token is the token you use with zrok enable to create a device environment for the current user. You get an account token when you create a zrok user. The zrok user can be created by the invitation/register procedure, or an admin can create the user directly. Most people will have only one zrok account token and use the same token to enable all their devices. You can find the account token in the web console in the pull-down menu where your email is displayed. The item is "Enable your environment."

After you have successfully enabled a zrok environment on a device, then you can run zrok status .

You can tell from the zrok status command whether or not your device has an enabled environment by looking at the output.

Not Enable Yet

To create a local environment use the zrok enable command.

Already Enabled


 Secret Token   <<SET>> 
 Ziti Identity  <<SET>> 

@ShashwatDubey99 Try the zrok status command and enable your current user's environment if needed. You may need to run zrok disable first in case there was a problem enabling the environment. Then, after you run zrok enable again, you'll be able to create shares.