ZAC visualisation issue

Hi everyone, I have successfully been running openziti with ZAC without issues on Ubuntu 22.04.3 LTS. Today I decided to update my version and followed the quickstart guide located at

which brought up both the controller and router successfully but then when I try install ZAC using th guide located at

all I get is the following when accessing the ZAC webpage

any ideas of what would cause this

Hi @Danieleb, it’s been a minute! Welcome back to the forum. I’m sorry you’re hitting this issue but I’ve had this same problem myself before.

I see from your screen capture you’re using “http” and not “https”. Is that intentional? I think the ZAC tries to send you over to https if it’s enabled and the quickstart guide does enable https using the self-signed certs from the quicsktart.

It might be that simple (I hope that’s the case). If not we’ll get to the bottom of it.

Thanks Clint, nice to be back :slight_smile:
I have tried with https and get following error
and if I try with wget I get
$ wget
–2023-08-17 14:13:17--
Connecting to… connected.
OpenSSL: error:0A00010B:SSL routines::wrong version number
Unable to establish SSL connection.

I have checked that the symlinks to the server.chain.pem and server.key are linked properly. But still no joy

Ah, for https, you’ll wnat to use :8443 not :1408. :slight_smile:

Thanks Clint you’re a star :grinning: I knew I was missing something

In the past I always accessed via port 1408 in plain http…

If you want to only use http, you can. the easiest thing to do is unlink the certs (bounce ZAC) and then only http will come online. Can you try that and then see if http works?

Also you run zac via node or do you run it from docker? I can try it locally too, but I’ve most definitely had this problem before and I think it’s when https is enabled and http tries to send you over to https

Am quite happy running over https.

It seems to be that when you access on port 1408 it redirects you to https always on port 1408 which gives you an incomplete page. If you however try open http on port 8443 it redirects you correctly and the page is properly rendered.

Aaaaahhh is that what's going on? That seems like it should be relatively easy to file. I'll give it a go and then file an issue if that's the case. Thanks for looking into that, it should be sending you to :8443 (obviously) :slight_smile: