Zrok and Portainer

I am using Zrok in Docker, using Portainer to edit my docker compose files. But I'm having a problem that is Docker/Portainer related but that I never encountered elsewhere than with zrok containers. So I'm trying to find what's wrong with zrok containers but I can't find any help on Portainer forums.

My problem is that when I install zrok as a Docker Compose in Portainer, Portainer tells me that " This stack was created outside of portainer" and doesn't let me edit it. This normally happens when a compose is deployed using Docker CLI but in my case, I deployed it using Portainer.

My full docker compose is here : "This stack was created outside of portainer"... but it was not · portainer · Discussion #10858 · GitHub

So I guess Zrok containers have a special argument or setting that make them un-editable by Portainer, but I can't find any solution.

Would you have an idea of what could be wrong ?
Thanks in advance for any answer and have a great day.

I don't use portainer myself so I'm probably not too much help. I assume you've searched the Internet and found references people saying: "This was my problem as well, stack name not matching the container name in the compose file caused this for me."?

I admit, I don't know what this means, myself. I dunno if there's anyone in the community using portainer yet that would comment here, but hopefully there is. Sorry I can't be more help. Have you looked at the Docker file for any hints or tried to use it to build a container?

@qrkourier, have you ever tried portainer?

I haven't used Portainer yet at all. It appears to be a UI for managing Docker Compose projects and Kubernetes deployments. zrok provides a few Compose projects that should work perfectly with Portainer.

In the GitHub issue you linked I see your temporary zrok public share compose project and nothing about that seems problematic. You might also be interested in a reserved zrok public share which provides a permanent subdomain for your share, optionally a one that you picked as a "unique name" (zrok frontdoor).

In the reddit thread I speculated it could have to do with the network definition, but that didn't seem right to OP.

I agree it must be some compose option, perhaps the depends_on directive, that Portainer doesn't support. Depending upon what property of the Compose project isn't supported by Portainer, it may be necessary to build a custom container image that performs some of the steps that are currently Compose services like init, enable, then share.