Error running ./setup.sh for Ansible demo

I am working through the following Ansible demo

I received the following error when running ./setup.sh

Before I ran this, I did run both of the following commands

pip install --user -r requirements.txt

ansible-galaxy collection install -r requirements.yaml

I am not really sure what it means…

Any tips?

I found this reference… so… I guess its best to just modify the deamon.json file and restart it

then… try rerunning the script

Starting to get stuck now… as I did that change… but it did not resolve the issue.

Confirming that I did restart the docker deamon after making this change

Has anyone else had this issue before?

I also tried this but it did not work either

export COMPOSE_DOCKER_CLI_BUILD=1

I am running the script on an Oracle Linux V8 micro instance. Not sure if that changes anything.

Any tips on how to get this script to work?

I tried to re-run this on another computer… with a fresh install.

Any tips?

@dovholuknf @qrkourier

Unfortunately. it fails on the same step

Hey @markamind, can you share the docker --version output on your host? This is indeed some issue in the specific docker version and BuildKit integration. I want to get a better understanding of whether we should modify the Dockerfiles to separately copy and chown files so as to avoid the issue altogether. The setup.sh already sets DOCKER_BUILDKIT=1, so there is something going on here.

1 Like

Cool… thanks for the note. I am really keen to have this demo working

Here is the version

Docker version 20.10.17, build 100c701

I look forward to your feedback

Thanks @markamind. I apologize, but could you also share the docker-compose --version output? If it’s at version >=1.25.0, can you append COMPOSE_DOCKER_CLI_BUILD=1 directly in the setup.sh script, prepending the DOCKER_BUILDKIT=1 line as such:

COMPOSE_DOCKER_CLI_BUILD=1 DOCKER_BUILDKIT=1 docker-compose build ...

See details below. Let me know if I need to upgrade to a more recent version.

docker-compose --version

docker-compose version 1.23.2, build 1110ad01

@markamind Thank you for sharing.

I’m inclined to change the way this works to not depend on BuildKit, as this is now the only functionality using it (I think). BuildKit integration for docker-compose seems to have been added in version 1.25.0, which was released late 2019:

For now, can you try upgrading your docker-compose version and retrying? Is the version you have installed the version that ships in your distribution’s base package repositories? You will still need to export COMPOSE_DOCKER_CLI_BUILD=1 or prepend it.

Thanks for your help in surfacing this issue.

1 Like

Thanks for the notes… when I installed docker compose… it was a random version.

I used the following commands to install 1.27.4… is there another version that would be better?

sudo curl -L "https://github.com/docker/compose/releases/download/1.27.4/docker-compose-$(uname -s)-$(uname -m)" -o /usr/local/bin/docker-compose

sudo chmod +x /usr/local/bin/docker-compose

sudo ln -s /usr/local/bin/docker-compose /usr/bin/docker-compose

Confirming its all up and running now

export COMPOSE_DOCKER_CLI_BUILD=1

export ZITI_SDK_SERVICE=".. copied from ZED...."

./setup.sh