Unable to Join Minecraft Server Using Zrok

So I followed this: GitHub - dovholuknf/minecraft-zrok-bootstrapper to join my friend's Minecraft server. It worked fine initially but then this started happening: -

Also, I have joined my friend's server a lot of times and see my laptop connected to many server like a web.

Is there any way to clear this up and make me join the server?

Hi @Ghostkwebb -- that's a strange issue you're seeing with the input/output error like that... it's not returning much of an error to understand what might have happened.

since you've run that script once and you know it's all setup correctly, would you try running a different command and we'll see if there's extra details to go on?

Try running:

c:\wherever\your\zrok\is\zrok.exe access private _put_the_share_token_here_ --bind --headless --verbose

replace the c:\wherever\your\zrok\is\zrok.exe with wherever the actual path is to the zrok.exe on your drive and replace _put_the_share_token_here_ with the actual share token.

I wonder if the verbose logging will give us any extra details as to why it has this "input/output error"...

I think it worked?

Yes that second command appeared to work. I did NOT test/try these scripts on macos though. I should indicate that they were only tested in Windows. That might be the problem?

Anyway, looks like it's working. Did you try Minecraft from your Mac?

Yes I tried on a Mac and everything works perfect now so I thank you very much!