When can I expect the next release?

I believe the issue we encountered wrt externalId and x509-claims will be available in the next release ( v0.26.9? ). May I know when the next release will be?


Hi @av-dev, I’m working on getting the release out, should be this week unless something unexpected comes up.



Hi @av-dev,
The 0.26.9 release is out.


Perfect. Thank you so much.

@plorenz I upgraded controller first , which went fine but when I tried to upgrade the first router, router kept crashing with following error -

[   0.985]    INFO fabric/router/xlink_transport.(*listener).bindSplitChannel |link, linkListener|: {routerId=[lAJSZUj5SG] linkProtocol=[tls] channelType=[ack] routerVersion=[v0.26.9] linkId=[4yNMqUFRqhB1pbg803Ox3T]} accepted part of split conn
[   0.985]    INFO fabric/router/handler_link.(*bindHandler).verifyRouter: {linkId=[4yNMqUFRqhB1pbg803Ox3T] routerId=[lAJSZUj5SG]} successfully verified router for link
[   0.985]    INFO fabric/router/handler_link.(*bindHandler).BindChannel: {routerId=[lAJSZUj5SG] routerVersion=[v0.26.9] linkId=[4yNMqUFRqhB1pbg803Ox3T]} link destination support heartbeats
[   0.986]    INFO fabric/router.(*xlinkAccepter).Accept: accepted new link [l/4yNMqUFRqhB1pbg803Ox3T]
[   0.986]    INFO fabric/router/xlink_transport.(*listener).bindSplitChannel |link, linkListener|: {linkId=[4yNMqUFRqhB1pbg803Ox3T] routerId=[lAJSZUj5SG] linkProtocol=[tls] channelType=[ack] routerVersion=[v0.26.9]} accepted link
[   1.051]    INFO fabric/router/xlink_transport.(*listener).bindSplitChannel |link, linkListener|: {routerVersion=[v0.26.9] linkId=[4yNMqUFRqhB1pbg803Ox3T] routerId=[lAJSZUj5SG] linkProtocol=[tls] channelType=[ack]} link registered
[   1.085]    INFO edge/tunnel/intercept.SetDnsInterceptIpRange: dns intercept IP range: -
panic: runtime error: index out of range [12] with length 0

goroutine 48 [running]:
github.com/orcaman/concurrent-map/v2.ConcurrentMap[...].Get({0x0?, 0xe36a70?, 0x37e11d600?}, {0xc00097bcb0?, 0x7092bbeaed4c7?})
	github.com/orcaman/concurrent-map/v2@v2.0.0/concurrent_map.go:85 +0x13e
	github.com/openziti/edge@v0.24.7/router/xgress_edge_tunnel/servicepoll.go:122 +0x74
github.com/openziti/edge/router/xgress_edge_tunnel.(*servicePoller).pollServices(0xc000112280, 0xc0000c07e0?, 0xc0000b3140)
	github.com/openziti/edge@v0.24.7/router/xgress_edge_tunnel/servicepoll.go:108 +0x10a
created by github.com/openziti/edge/router/xgress_edge_tunnel.(*tunneler).Start
	github.com/openziti/edge@v0.24.7/router/xgress_edge_tunnel/tunneler.go:92 +0x80d

am I missing something here? TIA

This is the process I followed to upgrade -

sudo systemctl stop router.service 
source ziti-cli-functions.sh
getZiti no
sudo systemctl start router.service
1 Like

Nice… that is much better than my manual process… thanks for sharing

1 Like

Thanks for the report, taking a look.

1 Like

FWIW - we have an open “help make ziti better” type issue for the upgrade path. it’s on “the tod list” provide 'upgrade' path for quickstart · Issue #779 · openziti/ziti · GitHub

1 Like

Fix should be out in 0.26.10 later today.


0.26.10 has been released with a fix for the panic. Appreciate the quick testing and bug report @av-dev and let us know if you encounter any other issues.


1 Like

Awesome. Thank you for getting this out so quickly.
I will upgrade in next few hours and get back in case of any issues.

1 Like

The update solved the panic for me in the new release. Thanks!

yeah, same here. I did first router upgrade and watched logs, didnt see any issues. Proceeding with rest of them.