Admin Console not connecting to Edge Controller

I got through the Initial Setup and did some playing around with services. and I wanted to take a deep dive into the admin console, install was easy but after connecting to the webpage I input what is in the documentation to connect to the edge controller and I get an error that says edge controller not online

service is running and present errors in the logs

What did you supply for the controller url? Did you remember to use ‘https’ not ‘http’? (that mistake is easy to make)

You should be using https://${public-url}:${edge-controller-port}.

Is that what you used?

like this - also port 8441 is the “host it anywhere” default per the doc as shown. that’s another easy mistake to make perhaps

Port issue i expect. 1280 vs 8441?

8441 has the same issue

oh - it’s entirely local. I didn’t realize it was a “host it local (no docker)”. We’ll have to dig in a tiny bit. You’re running this in linux, right? Can you access https://localhost:1280 ? does that return a response?

Well that is odd then. That “should” work. I’ll see if we can reproduce

Yes entirely local, it does appear I can access a web page

The OS hosting is Redhat

I’ll have to try RedHat. I have an Ubuntu install and it worked as expected. Is the latest RedHat OS what you’re on?

I am on a 7.9 install

probably selinux i would say, if you turn it off temporarily via setenforce does it work?
I got it working on almalinux 9, with selinux on, but had to add a couple of custom modules to work.

Very strange. After some fumbling around on my side with RHEL (signing up for a RedHat account, downloading 7.9, running it in a virtual machine, using firewall-cmd to open the ports), it ended up working for me properly.

It might be worthwhile to stop the ZAC and run it in debug mode. Instead of using the systemd file (created if you just run the install steps), maybe you can try to stop that service (systemctl stop ziti-console) and then run it from the command line node server.js debug, maybe some extra logging is shown in the console?

I can’t reproduce it yet. :frowning:

Still no joy, I turned off selinux just to be sure

I think I may have just found out why when I go to check the status of the controller nothing appears and when I try and start the controller it does not recognized the command

That’s really strange. Could it be something silly where /etc/hosts doesn’t have localhost declared and somehow the browser is doing the translation from localhost to 127.0.0.1?

Can you login with 127.0.0.1? As in using this for the controller url https://127.0.0.1:1280

on my RedHat it listens only on IPv6 but works:

LISTEN      0      128                                                                       [::]:1280                                                                                  [::]:*                   users:(("ziti-controller",pid=19512,fd=10))

I’m not really sure where to go here tbh. It’s really, really strange that the browser works but ZAC doesn’t…


That’d be strange since your browser is showing the response…

command to check the listening port:

ss -lntp | grep 1280

It is listening which is strange but the second it listens the browser no longer connects which is strange to me. /etc/hosts has localhost declared