After restart Can not command the Controller

Oh cool, i see. It’s an “air gapped” type of environment. Cool! Nice to have that option going forward. Thanks for bringing that to our attention.

1 Like

That is correct it is air gapped and besides the font which is being worked by Jeremy(Thanks again for the timely response) all our tests have passed so the project will keep moving forward to see if all use cases are met and if they are then the real fun beings

SOUNDS like fun! keep us posted either way? If something fails, we’d want to know that too. Thanks for the feedback.

1 Like

@cmbryner If you pull the latest it takes all of the functional cdn scripts but things like the map wont load because that has to be external. Let me know if you get further. Thanks

1 Like

Makes sense to me that the map won’t/can’t load since all those tiles are pulled down dynamically…

Pulled the Latest and it does work properly when starting the console manually

Starting as a service only port 1408 is connecting, I’m not all that great at service files so I believe that my service is just misconfigured I have that attached just to get confirmation

Looks ok to me. There’s a function found in you could emulate if you were really worried. The 1408 only connecting sounds to me like maybe you skipped a step linking the certs made from the quickstart? From here it’s bullet #3 Ziti Admin Console | OpenZiti

ln -s "${ZITI_PKI}/${ZITI_EDGE_CONTROLLER_HOSTNAME}-intermediate/certs/${ZITI_EDGE_CONTROLLER_HOSTNAME}-server.chain.pem" "${ZITI_HOME}/ziti-console/server.chain.pem"
ln -s "${ZITI_PKI}/${ZITI_EDGE_CONTROLLER_HOSTNAME}-intermediate/keys/${ZITI_EDGE_CONTROLLER_HOSTNAME}-server.key" "${ZITI_HOME}/ziti-console/server.key"

bullet #4 shows you how to create a systemd file and enable it:

sudo cp "${ZITI_HOME}/ziti-console.service" /etc/systemd/system
sudo systemctl daemon-reload
sudo systemctl enable --now ziti-console

Glad to see it’s working though!

createZacSystemdFile didn’t work when I called thats why I created my own will check the certs almost certain I copied those