startZitiController Command Not Found

When I use the following command to install OpenZiti, I can run startZitiController

However, when I log out and log back in, the command cannot be found

source /dev/stdin <<< "$(wget -qO- https://raw.githubusercontent.com/openziti/ziti/release-next/quickstart/docker/image/ziti-cli-functions.sh)"; expressInstall

I have tried reloading the env settings… but are not sure what I am doing wrong.

I tried to locate the source files… to trouble shoot… but do not know where to look… or what commands to use to search for these files… my shell bash is not that strong

. ~/.ziti/quickstart/$(hostname)/$(hostname).env

let me know if you have any tips

Just figured it out… the function is inside the installer…

So… if you download the file… you can rerun the function using the following command :slight_smile:

. ./ziti-cli-functions.sh && startZitiController

Shows you can teach an old dog some new tricks

It’s actually something I was planning on addressing some day. I experienced this myself. I’ll enter an issue to explain how this works a little more to hopefully help the next learner.

1 Like
1 Like

I am dealig with the same problem. However, it is not work amd shows following error:

ubuntu@ip-172-31-7-81:~/.ziti/quickstart/ip-172-31-7-81$ wget https://github.com/openziti/ziti/blob/release-next/quickstart/docker/image/ziti-cli-functions.sh
ubuntu@ip-172-31-7-81:~/.ziti/quickstart/ip-172-31-7-81$ ls -a
.   ip-172-31-7-81-edge-router.enrollment.log  ip-172-31-7-81-edge-router.yaml  ip-172-31-7-81.log   ziti-bin
..  ip-172-31-7-81-edge-router.jwt             ip-172-31-7-81-init.log          ip-172-31-7-81.yaml  ziti-cli-functions.sh
db  ip-172-31-7-81-edge-router.log             ip-172-31-7-81.env               pki                  ziti-cli.json

ubuntu@ip-172-31-7-81:~$ source ~/.ziti/quickstart/$(hostname -s)/$(hostname -s).env
 
                  ziti binaries are located at: /home/ubuntu/.ziti/quickstart/ip-172-31-7-81/ziti-bin/ziti-v0.27.5
add this to your path if you want by executing: export PATH=$PATH:/home/ubuntu/.ziti/quickstart/ip-172-31-7-81/ziti-bin/ziti-v0.27.5
ubuntu@ip-172-31-7-81:~$ export PATH=$PATH:/home/ubuntu/.ziti/quickstart/ip-172-31-7-81/ziti-bin/ziti-v0.27.5
ubuntu@ip-172-31-7-81:~$ echo $ZITI_HOME
/home/ubuntu/.ziti/quickstart/ip-172-31-7-81

ubuntu@ip-172-31-7-81:~$ source ~/.ziti/quickstart/$(hostname)/ziti-cli-functions.sh
-bash: /home/ubuntu/.ziti/quickstart/ip-172-31-7-81/ziti-cli-functions.sh: line 8: syntax error near unexpected token `newline'
-bash: /home/ubuntu/.ziti/quickstart/ip-172-31-7-81/ziti-cli-functions.sh: line 8: `<!DOCTYPE html>'

Any idea ?

yeah that link is “the old one”. You want to get the new link…

wget -q https://get.openziti.io/quick/ziti-cli-functions.sh -O $HOME/.ziti/quickstart/$(hostname -s)/ziti-cli-functions.sh

That will put the helper script into the default location for the quickstart. You can then source it:

source $HOME/.ziti/quickstart/$(hostname -s)/ziti-cli-functions.sh

Thank you so much. It works perfectly.

1 Like