Problem starting the Express Router

Not sure if I have broken something… most likely though.

I made a few policy change… to fix a few things up… but still had some issues… so I decided to stop and start the router and controller.

The controller restarted… but then I had issues restarting the router.

This has worked in the past…

[opc@instance-20220317-1005 ~]$ . ./ && startExpressEdgeRouter

[1] 295318

Express Edge Router started as process id: 295318. log located at: /home/opc/.ziti/quickstart/instance-20220317-1005/.log

for some reason… its not picking up the name of the router… even though I have loaded the env file.

Any tips?

What I may end up doing is to start from the top again… rather than try to fix this… but if there is something I can do to test… and debug… that would be awesome…

definitely getting better at finding my way around

ok… for some reason the router name is not being set…


seems as if this is not defined in the quickstart.env file

so it must be set during the Quick install process…

Hence… when you exit the terminal… and try to restart it… the router name is blank :slight_smile:

Fixed it… this was the variable that I needed to set :slight_smile:

export ZITI_EDGE_ROUTER_RAWNAME=instance-20220317-1005-edge-router

Seems like a bug in the quickstart. Express install should probably help you out. I’m on the mobile but I’ll check this when I get behind the keyboard

1 Like

Got it working now…

something for a new version
to add the creation of the ZITI_EDGE_ROUTER_RAWNAME variable into the QuickStart program

its not included in the env file :slight_smile:

issue filed at "all local" expressInstall doesn't know the name of startExpressEdgeRouter · Issue #668 · openziti/ziti · GitHub

1 Like

This is related… where the router_name variable is not being set when you load the environment variables