createZacSystemdFile not found

Following the Install the Ziti Console after an expressInstall setup, the createZacSystemdFile is not found. I should have added that this worked for me a while back but I have not tried an installation in a few months.

I was doing something wrong or there was an update as I am unable to reproduce (was fairly certain I had sourced the environment but not doing so is the most probable explanation).

I expect you left the shell and came back to it or were in a seperate terminal. Some (most) of the quickstart functions are not re-applyed unless you source the helper script. If you just re-source (without running expressInstall) like this:

source /dev/stdin <<< "$(wget -qO-";

I think you’ll have the functions you’re missing.

1 Like

I have been reinstalling looking to ensure everything is ready on a particular distro or two and it worked nicely last time so I am fairly confident you’re exactly right. OT: (and I will start a separate thread) I have had some what I now believe are minor issues with SELinux that I have not seen solutions for with my limited searching.