Infinite loop of use of closed network connection

Hello. I'm using zrok app for a while for purpose of playing Minecraft with my friends.
I'm the host of the server and I usually use zrok share reserved --headless TOKEN - v with my reserved TOKEN.
On side of users used command is zrok access private TOKEN --bind
Token target on server side is also
Last 3 months of playing there was no problem but last week I saw on both sides user and server infinite loop of starting and closing connections.
Then infinite loop with error continues until I stop client app. Last months I used older version of zrok, after update to latest 4.33 problem steal occurs.
I tried to reserve new token and create new account.
I've tried to start client session from my private network and from outside, problem is still the same.
I would be glad for any advice in this situation.

Hi @RadoslawDebinski welcome to the community and to zrok (and OpenZiti)!

Thanks for reporting an issue, obviously we don't expect that sort of behavior but I'm happy you've been using zrok for months so you know it's usually quite nice!

Does it happen immediately or only after some amount of time? Is it highly reproducible? Since you're posting here -- I would suspect it happens a lot but knowing if it's everytime or sometimes helps.

Can anyone join successfully? Does it happen after the first / second / third joins, etc. Any extra details would be helpful.


Hi. I can say I resolved issue but now I'm curious why it worked :sweat_smile:.
So the issue were highly reproducible because I started my server on port 49152 and client on 25565 and by mistake I connected with token my client with my client so 25565 with 25565 and I think this is why I didn't see any behaviour on Minecraft server's logs but zrok share command console started to close double connections in endless loop. Now I'm interested in why this worked for few months because I'm pretty sure my script responsible for reserving token always used 25565 instead of 49152 where server runs. Any ideas?

1 Like

Not really sure. Best guess is that maybe you had more than one zrok instance running? Maybe? Without digging in and doing some diagnosing, it's hard to know for sure. I heard "issue resolved" though, so I'm gonna take that win. :slight_smile:

The fact that it was running for "months" and then something happened -- not gonna lie -- sounds like something us humans have a tendency to do. :slight_smile: We're not nearly as good at doing exactly the same procedure as that script/computer is... lol

If you get into a bind again though and can't sort out what's going on, hit us back up and we'll try to help! Very glad it's all sorted now, happy zrok'ing!

1 Like