Unable to add auth policy to ZAC

Just updated from ZAC 2.5.1 to 2.6.8 to finally get to play around with Auth policies. This is all through docker. However, when I attempt to add an auth policy

and press save, I get this

That is, kicked back to the log in screen. I can create user identities fine, just cannot do this.
I haven’t got a test bed to play around with a clean slate, but wondering if anyone else is experiencing this or wonder if this is just a me problem, or something else?

1 Like

I’ve seen the ZAC log you out when you hit an error like this. Since this form is “relatively new”, my guess would be that there’s some kind of bug involved. Does the ZAC or the controller log show you anything useful? Or does “developer tools” show you an error?

If you clicked ‘save’ on that form, it’s definitely invalid since you didn’t select a “jwt signers” in the drop-down. It might just be form validation that’s causing you to get booted…

@jeremy.tellier - can you try to reproduce?

Ooops. I’m mistaken. That’s the secondary policy, my bad… That shouldn’t matter. I’ll try it out on my fresh install.

Just logged a Github issue (Policy overview different to edit view... · Issue #136 · openziti/ziti-console · GitHub), as I get this difference when looking at the default one.

The only item I get in the ZAC logs is “Session: 4e085c65-b257-4844-907a-795df5dxxxxx” when I press save (I have x’d out the last digits).

I am getting nothing in my controller log, but that may because I haven’t bumped up my logging (now where was that post again…)

I do see you didn’t select any of the radio policies. I just tried to make one and I do have an ext-jwt-signer configured. I tried to submit this and also failed and got logged out:


I also have one that I made from the command line and when I open it up, it looks “broken”… I think @jeremy.tellier will need to give this a look.

Thanks @TheLumberjack. I did create one with all the buttons pressed, and that failed as well. Will wait for Jeremy

I do see a couple issues, will be working on an update today to resolve these. Thanks @gooseleggs!

Ok all, 2.6.9 should resolve these issues, please do tag me if you see any more problems, that UI is fresh and not tested a lot in the wild. Thanks!